summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-22 15:24:54 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-23 22:01:27 +0200
commit007176e7103fc25bca295c7b09578a37f5d635c7 (patch)
tree262be679023254506b6a838247964b8ffe95a376
parent6e864d0081779f4bde3607fa7ea02bbb52f7ce3f (diff)
gnu: python-pyparsing: Use 'modify-phases' syntax.
* gnu/packages/python.scm (python-pyparsing)[arguments]<#:phases>: Use 'modify-phases'.
-rw-r--r--gnu/packages/python.scm36
1 files changed, 17 insertions, 19 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e7a40dfcdd..a8e3186bec 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3955,26 +3955,24 @@ library, libgit2 implements Git plumbing.")
(outputs '("out" "doc"))
(arguments
`(#:tests? #f ; no test target
- #:modules ((guix build python-build-system)
- (guix build utils))
#:phases
- (alist-cons-after
- 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((doc (string-append (assoc-ref outputs "doc")
- "/share/doc/" ,name "-" ,version))
- (html-doc (string-append doc "/html"))
- (examples (string-append doc "/examples")))
- (mkdir-p html-doc)
- (mkdir-p examples)
- (for-each
- (lambda (dir tgt)
- (map (lambda (file)
- (install-file file tgt))
- (find-files dir ".*")))
- (list "docs" "htmldoc" "examples")
- (list doc html-doc examples))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((doc (string-append (assoc-ref outputs "doc")
+ "/share/doc/" ,name "-" ,version))
+ (html-doc (string-append doc "/html"))
+ (examples (string-append doc "/examples")))
+ (mkdir-p html-doc)
+ (mkdir-p examples)
+ (for-each
+ (lambda (dir tgt)
+ (map (lambda (file)
+ (install-file file tgt))
+ (find-files dir ".*")))
+ (list "docs" "htmldoc" "examples")
+ (list doc html-doc examples))
+ #t))))))
(home-page "http://pyparsing.wikispaces.com")
(synopsis "Python parsing class library")
(description