summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-12-24 16:23:50 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-12-27 11:51:15 -0500
commit15b60fc3138e9d601aff3e3317373ed465e6ea93 (patch)
treee2475e5eec1a32c6f17ca4d88980df6b25acbb5a
parentaa498fc00320d38a37668e2b024bdc7337434c07 (diff)
gnu: python-pillow: Fix test failures on i686-linux and armhf-linux.
* gnu/packages/patches/python-pillow-fix-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-pillow)[source]: Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pillow-fix-failing-tests.patchbin0 -> 112373 bytes
-rw-r--r--gnu/packages/python.scm4
3 files changed, 4 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 586f023ee6..2c4305d94c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1016,6 +1016,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-networkx2-reproducible-build.patch \
%D%/packages/patches/python-nose-timer-drop-ordereddict.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \
+ %D%/packages/patches/python-pillow-fix-failing-tests.patch \
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
%D%/packages/patches/python-statsmodels-fix-tests.patch \
%D%/packages/patches/python-scikit-learn-fix-test-non-determinism.patch \
diff --git a/gnu/packages/patches/python-pillow-fix-failing-tests.patch b/gnu/packages/patches/python-pillow-fix-failing-tests.patch
new file mode 100644
index 0000000000..2575d6f612
--- /dev/null
+++ b/gnu/packages/patches/python-pillow-fix-failing-tests.patch
Binary files differ
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ff1e78bbe..ce3aa299bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3739,7 +3739,9 @@ the OleFileIO module from PIL, the Python Image Library.")
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))))
+ "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))
+ (patch-flags '("-p1" "--binary"))
+ (patches (search-patches "python-pillow-fix-failing-tests.patch"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))