summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-12-02 17:53:14 -0600
committerEric Bavier <bavier@member.fsf.org>2018-12-02 17:56:05 -0600
commit6efccabe4e2e3ea1bd14cd0e81bdb83d5f6baaea (patch)
tree1cb4e31f1dec5bdcf552a7906a3d33df10eae039
parent6776af04d4b65c5a9a07784307a6abe395b6f480 (diff)
guile-json: Download source from savannah.
* gnu/packages/guile.scm (guile-json)[source]: Download tarball from savannah. Remove 'file-name' field. [native-inputs]: Remove autoconf and automake; tarball is bootstrapped.
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 41f2b16e0a..7fcb4a400c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -929,16 +929,13 @@ for Guile\".")
(home-page "https://github.com/aconchillo/guile-json")
(source (origin
(method url-fetch)
- (uri (string-append home-page "/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://download.savannah.nongnu.org/releases/"
+ name "/" name "-" version ".tar.gz"))
(sha256
(base32
- "02kqv0q98fmchn7i4y7ycmrjlh4b2c93ij0z7k036qwpp204w4gh"))))
+ "15gnb84d7hpazqhskkf3g9z4r6knw54wfj4ch5270kakz1lp70c9"))))
(build-system gnu-build-system)
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
+ (native-inputs `(("pkg-config" ,pkg-config)
("guile" ,guile-2.2)))
(inputs `(("guile" ,guile-2.2)))
(synopsis "JSON module for Guile")