summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-06-26 21:07:10 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-23 10:29:35 +1000
commitbca2c57658db1fdccca996cd59a3b43f739f0d87 (patch)
tree5a3e3d71f1a51ea04704f9e36d6a00052fcd022a
parent98593f9f51c8f6e3c2208d8443fdf08cf4d633bb (diff)
gnu: bamm: Use htslib-1.3.
* gnu/packages/bioinformatics (htslib-1.3): New variable. (bamm)[inputs]: Replace htslib with htslib-1.3.
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87da4aed15..53239cb697 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -248,7 +248,7 @@ structure of the predicted RNA.")
("python-nose" ,python2-nose)
("python-pysam" ,python2-pysam)))
(inputs
- `(("htslib" ,htslib)
+ `(("htslib" ,htslib-1.3) ; At least one test fails on htslib-1.4+.
("samtools" ,samtools)
("bwa" ,bwa)
("grep" ,grep)
@@ -3079,6 +3079,20 @@ data. It also provides the bgzip, htsfile, and tabix utilities.")
;; the rest is released under the Expat license
(license (list license:expat license:bsd-3))))
+;; This package should be removed once no packages rely upon it.
+(define htslib-1.3
+ (package
+ (inherit htslib)
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/samtools/htslib/releases/download/"
+ version "/htslib-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1rja282fwdc25ql6izkhdyh8ppw8x2fs0w0js78zgkmqjlikmma9"))))))
+
(define-public idr
(package
(name "idr")