summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-02 00:23:55 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-02 00:24:32 +0100
commite627052f3c9db4010f2ae8d0d1c04fa710b576fe (patch)
tree8f179b18de66c8afa5cfef3dd7a495f614f60f41
parent47f92fbb1062cb19201347324285fa9aea8e443d (diff)
gnu: silkaj: Update to 0.6.0.
* gnu/packages/finance.scm (silkaj): Update to 0.6.0. [arguments]: Remove #:phases since upstream improved install process.
-rw-r--r--gnu/packages/finance.scm26
1 files changed, 3 insertions, 23 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 28bfb28f49..73662cc388 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -875,7 +875,7 @@ main features are:
(define-public silkaj
(package
(name "silkaj")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method git-fetch)
@@ -885,30 +885,10 @@ main features are:
(file-name (git-file-name name version))
(sha256
(base32
- "0xy25lpgz04nxikjvxlnlckrc9xmsxyiz2qm0bsiid8cnbdqcn12"))))
+ "02n028rz1pshgh7w0af3b291r8lwvhzskm1q98d991gr8rscvad2"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ;no test
- #:phases
- (modify-phases %standard-phases
- ;; The program is just a bunch of Python files in "src/" directory.
- ;; Many phases are useless. However, `python-build-system' correctly
- ;; sets PYTHONPATH and patches Python scripts.
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/silkaj"))
- (executable (string-append share "/silkaj.py"))
- (bin (string-append out "/bin")))
- ;; Install data.
- (copy-recursively "src" share)
- ;; Install executable.
- (mkdir-p bin)
- (with-directory-excursion bin
- (symlink executable "silkaj")))
- #t)))))
+ `(#:tests? #f)) ;no test
(inputs
`(("python-commandlines" ,python-commandlines)
("python-ipaddress" ,python-ipaddress)