summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-12-01 22:28:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-01 23:56:32 +0100
commitf5cc5ead58543d9e56647fd1426109154278bf4e (patch)
treead8e81352035bac95d4638f1a54bec323f6ba07a
parenta52461ded1b3ab46f13e0501bf8d37e0a7ce269f (diff)
gnu: Add java-xmlunit-matchers.
* gnu/packages/java.scm (java-xmlunit-matchers): New variable.
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0c7b9a9855..d5bd11178b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9670,6 +9670,37 @@ against expected outcomes.")
(native-inputs
`(("java-mockito-1" ,java-mockito-1)))))
+(define-public java-xmlunit-matchers
+ (package
+ (inherit java-xmlunit)
+ (name "java-xmlunit-matchers")
+ (arguments
+ `(#:jar-name "java-xmlunit-matchers.jar"
+ #:source-dir "xmlunit-matchers/src/main/java"
+ #:test-dir "xmlunit-matchers/src/test"
+ #:test-exclude
+ ;; Cannot open xsd for http://www.xmlunit.org/test-support/Book.xsd
+ (list "**/ValidationMatcherTest.java")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-test-class
+ (lambda _
+ (copy-file "xmlunit-core/src/test/java/org/xmlunit/TestResources.java"
+ "xmlunit-matchers/src/test/java/org/xmlunit/TestResources.java")
+ #t))
+ (add-before 'build 'fix-test-resources-path
+ (lambda _
+ (substitute* (find-files "xmlunit-matchers/src/test" ".*.java")
+ (("../test-resources") "test-resources"))
+ #t))
+ (add-before 'check 'copy-test-resources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "resources") "test-resources")
+ #t)))))
+ (inputs
+ `(("java-xmlunit" ,java-xmlunit)
+ ("java-junit" ,java-junit)))))
+
(define-public java-openchart2
(package
(name "java-openchart2")