summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-07-21 16:37:23 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-21 16:39:38 +0200
commit8dc797fa28d237f30979166bf924c7919d12f88d (patch)
tree420493e99e94a201beab5b14bc3fcdaf0828efb0
parent5ff0edaee6942a21d20624aade41a228932fb372 (diff)
gnu: Add aragorn.
* gnu/packages/bioinformatics.scm (aragorn): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 78cd3ce321..b38b9c8bb5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -54,6 +54,54 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages zip))
+(define-public aragorn
+ (package
+ (name "aragorn")
+ (version "1.2.36")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://mbio-serv2.mbioekol.lu.se/ARAGORN/Downloads/aragorn"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1dg7jlz1qpqy88igjxd6ncs11ccsirb36qv1z01a0np4i4jh61mb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (zero? (system* "gcc"
+ "-O3"
+ "-ffast-math"
+ "-finline-functions"
+ "-o"
+ "aragorn"
+ (string-append "aragorn" ,version ".c")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man1")))
+ (mkdir-p bin)
+ (copy-file "aragorn"
+ (string-append bin "/aragorn"))
+ (mkdir-p man)
+ (copy-file "aragorn.1"
+ (string-append man "/aragorn.1")))
+ #t)))))
+ (home-page "http://mbio-serv2.mbioekol.lu.se/ARAGORN")
+ (synopsis "Detect tRNA, mtRNA and tmRNA genes in nucleotide sequences")
+ (description
+ "Aragorn identifies transfer RNA, mitochondrial RNA and
+transfer-messenger RNA from nucleotide sequences, based on homology to known
+tRNA consensus sequences and RNA structure. It also outputs the secondary
+structure of the predicted RNA.")
+ (license license:gpl2)))
+
(define-public bamtools
(package
(name "bamtools")