summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2015-07-10 15:49:07 -0500
committerLudovic Courtès <ludo@gnu.org>2015-07-19 23:17:52 +0200
commitf4de5b3bf116d965a41cdeebb5423cdd15168c2b (patch)
tree966dd9e2242e748eeb2df965ba74f02a73410483
parent093ae1be9bdec56709f546ec5ffed20d34957e8f (diff)
gnu: Add python-feedgenerator.
* gnu/packages/python.scm (python-feedgenerator, python2-feedgenerator): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2eaa3176d..0788da0ff3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2067,6 +2068,44 @@ sources.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+(define-public python-feedgenerator
+ (package
+ (name "python-feedgenerator")
+ (version "20150710.97185b7")
+ (source
+ ;; Using the git checkout for now because license file not added till
+ ;; https://github.com/dmdm/feedgenerator-py3k/commit/97185b7566c240c4bf5ed80db7d6c271204dab39
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmdm/feedgenerator-py3k.git")
+ (commit "97185b7566c240c4bf5ed80db7d6c271204dab39")))
+ (sha256
+ (base32
+ "0dbd6apij5j1923ib905x0srgcyls4wlabqlwp4dzkwmksvnrr2a"))))
+ (arguments
+ `(;; With standard flags, the install phase attempts to create a zip'd
+ ;; egg file, and fails with an error: 'ZIP does not support timestamps
+ ;; before 1980'
+ #:configure-flags '("--single-version-externally-managed"
+ "--record=feedgenerator.txt")))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pytz" ,python-pytz)
+ ("python-six" ,python-six)))
+ (home-page
+ "https://github.com/dmdm/feedgenerator-py3k.git")
+ (synopsis
+ "Standalone version of Django's Atom/RSS feed generator")
+ (description
+ "Feedgenerator-py3k is a standalone version of Django's feedgenerator,
+which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
+ (license bsd-3)))
+
+(define-public python2-feedgenerator
+ (package-with-python2 python-feedgenerator))
+
(define-public python-scikit-learn
(package
(name "python-scikit-learn")