summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-10-12 00:47:16 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-11-03 21:38:13 +0100
commit2ac9ba6a2914c73ff83dbd7b4ba7b47333476685 (patch)
treea8ee597264f1ba9a9107ed21308c0959c4e1e14a
parentabf21efcae3bb52b463c6b92f7b9132ba1c0bfa8 (diff)
gnu: Add python-hacking.
* gnu/packages/openstack.scm (python-hacking, python2-hacking): New variables.
-rw-r--r--gnu/packages/openstack.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4fd1c803ff..fc868814f7 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -100,6 +100,40 @@ manner.")
(define-public python2-debtcollector
(package-with-python2 python-debtcollector))
+(define-public python-hacking
+ (package
+ (name "python-hacking")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hacking" version))
+ (sha256
+ (base32
+ "1a310k3dv04jg7zvmk37h2ql7y9kf4hvdxb74bjlwdxgmy6h4wap"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flake8-2.2.4" ,python-flake8-2.2.4)
+ ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
+ ("python-pbr" ,python-pbr)
+ ("python-pep8-1.5.7" ,python-pep8-1.5.7)
+ ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
+ ("python-six" ,python-six)))
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ;; Tests
+ ("python-testscenarios" ,python-testscenarios)))
+ (home-page "http://github.com/openstack-dev/hacking")
+ (synopsis "OpenStack hacking guideline enforcement")
+ (description
+ "Python-hacking is a set of flake8 plugins that test and enforce the
+@uref{http://docs.openstack.org/developer/hacking/, OpenStack style
+guidelines}.")
+ (license asl2.0)))
+
+(define-public python2-hacking
+ (package-with-python2 python-hacking))
+
(define-public python-mox3
(package
(name "python-mox3")