summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-04 09:28:46 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-04 09:28:46 +0100
commit9e6b9ea4b18defa78b8e1e997e8c834db99a121c (patch)
tree9bcd80ade58d72db06df7cbef4bb61a991d93cab
parent2666a126ef48da1dd5ee8465af0aeaf66216d75f (diff)
gnu: clang-runtime: Mark MIPS as unsupported.
* gnu/packages/llvm.scm (clang-runtime-from-llvm): Add 'supported-systems' field.
-rw-r--r--gnu/packages/llvm.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 18e0ca9c76..d5e5ed65ad 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -87,7 +87,10 @@ of programming tools as well as libraries with equivalent functionality.")
functions for C and C++ programs. It also provides header files that allow C
and C++ source code to interface with the \"sanitization\" passes of the clang
compiler. In LLVM this library is called \"compiler-rt\".")
- (license ncsa)))
+ (license ncsa)
+
+ ;; <http://compiler-rt.llvm.org/> doesn't list MIPS as supported.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))
(define (clang-from-llvm llvm clang-runtime hash)
(package