summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-01 23:00:11 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-01 23:20:56 +0200
commit2472cdec25f440802e2c9b2904dd5a9cfce677b4 (patch)
tree1fdf02bd4d9cbb70873785c90dc7c3bdd126a868
parent0e558640361b6ab4aac0f424cb587b21a642bab8 (diff)
gnu: gnome-shell: Store absolute file name of 'ibus-daemon'.
* gnu/packages/gnome.scm (gnome-shell)[arguments]: Add 'record-absolute-file-names' phase.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a489137669..477a550943 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5764,6 +5764,13 @@ properties, screen resolution, and other GNOME parameters.")
;; Convert the logo from SVG to PNG.
(invoke "inkscape" "--export-png=data/theme/guix-logo.png"
"data/theme/guix-logo.svg")))
+ (add-before 'build 'record-absolute-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "js/misc/ibusManager.js"
+ (("'ibus-daemon'")
+ (string-append "'" (assoc-ref inputs "ibus")
+ "/bin/ibus-daemon'")))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))