summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-29 10:41:11 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-29 12:19:24 +0200
commitda56f10971e0b6f32969b10e38ed043b2c99bb82 (patch)
tree7e1a95c55132367828a67c1febb7bcdc73951976
parent9d3053819dfd834a1c29a03427c41d8524b8a7d5 (diff)
guix package: Add 'guix search' alias.
* guix/scripts/search.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add it. * tests/guix-package-aliases.sh: Add test. * doc/guix.texi (Invoking guix package): Document it and use it in a couple of examples.
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi13
-rw-r--r--guix/scripts/search.scm67
-rw-r--r--po/guix/POTFILES.in1
-rw-r--r--tests/guix-package-aliases.sh2
5 files changed, 79 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 076f1c7a71..36f3bc5c27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,6 +227,7 @@ MODULES = \
guix/scripts/install.scm \
guix/scripts/remove.scm \
guix/scripts/upgrade.scm \
+ guix/scripts/search.scm \
guix/scripts/gc.scm \
guix/scripts/hash.scm \
guix/scripts/pack.scm \
diff --git a/doc/guix.texi b/doc/guix.texi
index 39d2ee476a..fcee57d9cd 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -2630,6 +2630,8 @@ For your convenience, we also provide the following aliases:
@itemize
@item
+@command{guix search} is an alias for @command{guix package -s},
+@item
@command{guix install} is an alias for @command{guix package -i},
@item
@command{guix remove} is an alias for @command{guix package -r},
@@ -2953,12 +2955,13 @@ name: gmp
@dots{}
@end example
-It is also possible to refine search results using several @code{-s}
-flags. For example, the following command returns a list of board
-games:
+It is also possible to refine search results using several @code{-s} flags to
+@command{guix package}, or several arguments to @command{guix search}. For
+example, the following command returns a list of board games (this time using
+the @command{guix search} alias):
@example
-$ guix package -s '\<board\>' -s game | recsel -p name
+$ guix search '\<board\>' game | recsel -p name
name: gnubg
@dots{}
@end example
@@ -2973,7 +2976,7 @@ for cryptographic libraries, filters out Haskell, Perl, Python, and Ruby
libraries, and prints the name and synopsis of the matching packages:
@example
-$ guix package -s crypto -s library | \
+$ guix search crypto library | \
recsel -e '! (name ~ "^(ghc|perl|python|ruby)")' -p name,synopsis
@end example
diff --git a/guix/scripts/search.scm b/guix/scripts/search.scm
new file mode 100644
index 0000000000..8fceb83668
--- /dev/null
+++ b/guix/scripts/search.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts search)
+ #:use-module (guix ui)
+ #:use-module (guix scripts package)
+ #:use-module (guix scripts)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (srfi srfi-37)
+ #:export (guix-search))
+
+(define (show-help)
+ (display (G_ "Usage: guix search [OPTION] REGEXPS...
+Search for packages matching REGEXPS."))
+ (display (G_"
+This is an alias for 'guix package -s'.\n"))
+ (newline)
+ (display (G_ "
+ -h, --help display this help and exit"))
+ (display (G_ "
+ -V, --version display version information and exit"))
+ (newline)
+ (show-bug-report-information))
+
+(define %options
+ ;; Specification of the command-line options.
+ (list (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ (option '(#\V "version") #f #f
+ (lambda args
+ (show-version-and-exit "guix search")))))
+
+(define (guix-search . args)
+ (define (handle-argument arg result)
+ ;; Treat all non-option arguments as regexps.
+ (cons `(query search ,(or arg ""))
+ result))
+
+ (define opts
+ (args-fold* args %options
+ (lambda (opt name arg . rest)
+ (leave (G_ "~A: unrecognized option~%") name))
+ handle-argument
+ '()))
+
+ (unless (assoc-ref opts 'query)
+ (leave (G_ "missing arguments: no regular expressions to search for~%")))
+
+ (guix-package* opts))
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index 91de60efc7..ceee589b2e 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -44,6 +44,7 @@ guix/scripts/package.scm
guix/scripts/install.scm
guix/scripts/remove.scm
guix/scripts/upgrade.scm
+guix/scripts/search.scm
guix/scripts/gc.scm
guix/scripts/hash.scm
guix/scripts/import.scm
diff --git a/tests/guix-package-aliases.sh b/tests/guix-package-aliases.sh
index 64ed2fbb67..5c68664093 100644
--- a/tests/guix-package-aliases.sh
+++ b/tests/guix-package-aliases.sh
@@ -56,3 +56,5 @@ then false; else true; fi
if guix remove -i guile-bootstrap -p "$profile" --bootstrap
then false; else true; fi
+
+guix search '\<board\>' game | grep '^name: gnubg'