summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-15 20:53:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-15 21:23:57 +0200
commit5af7428b796ae4da9a35453f2ba03108673178ac (patch)
treeff7fdad0f925b8e76b66fd5a6c9da59d04901603
parente8e2281ee98a74e54b655f697523516651eb1722 (diff)
gnu: ubridge: Don't use unstable tarball.
* gnu/packages/networking.scm (ubridge)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 2ec3f37925..4481373fa8 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2218,21 +2218,22 @@ SNMP v3 using both IPv4 and IPv6.")
(package
(name "ubridge")
(version "0.9.15")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/GNS3/ubridge/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0nmj37s7wvl7c36qbdv33rk9fyniwfk73qwb61ingni5siw67mr3"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GNS3/ubridge.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fl07zyall04map6v2l1bclqh8y3rrhsx61s2v0sr8b00j201jg4"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no tests
+ `(#:tests? #f ; no tests
#:make-flags '("CC=gcc")
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-before 'install 'set-bindir
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out")