summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-05-15 15:12:13 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-15 15:22:22 +0200
commit79bfa42287f98e72b99e7165280e2750fad46cd3 (patch)
treed591648722c10583207d266acf9df06564b91e72
parent33572a36624aa1c5cca409cfee36eb67982f4891 (diff)
gnu: Add python-pylzma.
* gnu/packages/python-xyz.scm (python-pylzma): New variable. (python2-pylzma): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ed1ebdd3c..024fc96f35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15665,3 +15665,24 @@ processes may share the same data.")
(description "A Sphinx extension to convert SVG images to PDF in case the builder does not support
SVG images natively (e.g. LaTeX).")
(license license:bsd-3)))
+
+(define-public python-pylzma
+ (package
+ (name "python-pylzma")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pylzma" version))
+ (sha256
+ (base32
+ "074anvhyjgsv2iby2ql1ixfvjgmhnvcwjbdz8gk70xzkzcm1fx5q"))))
+ (build-system python-build-system)
+ (home-page "http://www.joachim-bauch.de/projects/pylzma/")
+ (synopsis "Python bindings for the LZMA library by Igor Pavlov.")
+ (description "This package provides Python bindings for the LZMA library
+by Igor Pavlov.")
+ (license license:lgpl2.1+)))
+
+(define-public python2-pylzma
+ (package-with-python2 python-pylzma))