summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-15 15:13:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-15 17:47:48 -0400
commitb8e5de56086ad0d76573849ca996122549b56b38 (patch)
treee61de0c55f028493b92fe7116afcae528083c8aa
parentdc555d86e168f15b24bae9a6612c1d22f79cdd75 (diff)
gnu: python-jedi: Update to 0.13.3.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.13.3. (python2-jedi): Enable tests.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 024fc96f35..5322b70759 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10290,17 +10290,17 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.13.2")
+ (version "0.13.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
(sha256
(base32
- "1za944msp0f8x36qa8l309jhv0kzlsdh7r9nj3z12y8npnsh45sp"))))
+ "0nsrjlb57njqppxmi8wjsb1dkad7qa7svx67jbkhixq66lz61c1b"))))
(build-system python-build-system)
(arguments
- `( ;; Many tests are failing with Python 3.7.x as of version 0.13.2 (see:
+ `( ;; Many tests are failing with Python 3.7.x as of version 0.13.3 (see:
;; https://github.com/davidhalter/jedi/issues/1263)
#:tests? #f
#:phases
@@ -10326,7 +10326,11 @@ well.")
(license license:expat)))
(define-public python2-jedi
- (package-with-python2 python-jedi))
+ (let ((base (package-with-python2 (strip-python2-variant python-jedi))))
+ (package
+ (inherit base)
+ (arguments (substitute-keyword-arguments (package-arguments base)
+ ((#:tests? _) #t))))))
(define-public ptpython
(package