summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-16 13:42:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-16 13:45:23 +0200
commitfbeb92d7607dc1dc6c3a34a536352636274a69de (patch)
treedb997a6f22ea3cb8101dc7d5fbc416bd67f4f093
parenta4ff3255d46ea7ef4be44367de27d6978776d0fe (diff)
gnu: custom-gcc: Unhide resulting package.
This is a follow-up to commit d78010b81ee6ef4fd8803082e2f401b9e55b44db. While the plain "gcc" packages should be hidden by default, gcc-derived packages like "gfortran" should not. * gnu/packages/gcc.scm (custom-gcc)[properties]: Remove the 'hidden? property.
-rw-r--r--gnu/packages/gcc.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 05238b0315..cd75571871 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
@@ -614,6 +614,7 @@ as the 'native-search-paths' field."
(package-outputs gcc)
(delete "lib" (package-outputs gcc))))
(native-search-paths search-paths)
+ (properties (alist-delete 'hidden? (package-properties gcc)))
(arguments
(substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
(guix build utils)