summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-13 09:39:36 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-13 10:17:00 -0500
commit4e01bc440a4f20bf1597db2ed852e541da45efce (patch)
treea3e5466296c25ce100c9dbddf52796344019c5ee
parentc410e9e531b999546f033d35266f8ac488dee7e0 (diff)
gnu: python-pysam: Update to version 0.16.0.1.
The check phase was failing with: starting phase `check' make: Entering directory '...drv-0/python-pysam-0.15.1-checkout/tests/pysam_data' samtools faidx ex1.fa samtools import ex1.fa.fai ex1.sam.gz ex1.bam [main] "samtools import" has been removed. Please use "samtools view" instead. make: *** [Makefile:56: ex1.bam] Error 1 * gnu/packages/bioinformatics.scm (python-pysam): Update to version 0.16.0.1. [phases]{check}: Delete a couple more failing test files. [native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4c49b00252..f63ae5f324 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018, 2019, 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
@@ -1894,7 +1894,7 @@ multiple sequence alignments.")
(define-public python-pysam
(package
(name "python-pysam")
- (version "0.15.1")
+ (version "0.16.0.1")
(source (origin
(method git-fetch)
;; Test data is missing on PyPi.
@@ -1904,7 +1904,7 @@ multiple sequence alignments.")
(file-name (git-file-name name version))
(sha256
(base32
- "1vj367w6xbn9bpmksm162l1aipf7cj97h1q83y7jcpm33ihwpf7x"))
+ "168bwwm8c2k22m7paip8q0yajyl7xdxgnik0bgjl7rhqg0majz0f"))
(modules '((guix build utils)))
(snippet '(begin
;; Drop bundled htslib. TODO: Also remove samtools
@@ -1934,8 +1934,13 @@ multiple sequence alignments.")
;; This file contains tests that require a connection to the
;; internet.
(delete-file "tests/tabix_test.py")
- ;; FIXME: This test fails
+ ;; These tests fail (see:
+ ;; https://github.com/pysam-developers/pysam/issues/939).
+ (delete-file "tests/compile_test.py")
(delete-file "tests/AlignmentFile_test.py")
+ (delete-file "tests/AlignmentFileHeader_test.py")
+ (delete-file "tests/StreamFiledescriptors_test.py")
+ (delete-file "tests/VariantRecord_test.py")
;; Add first subdirectory of "build" directory to PYTHONPATH.
(setenv "PYTHONPATH"
(string-append
@@ -1965,7 +1970,8 @@ multiple sequence alignments.")
;; Dependencies below are are for tests only.
("samtools" ,samtools)
("bcftools" ,bcftools)
- ("python-nose" ,python-nose)))
+ ("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/pysam-developers/pysam")
(synopsis "Python bindings to the SAMtools C API")
(description