summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-05-18 20:15:24 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-05-18 20:19:59 +0200
commit0062a2e0e09451ddde9b776fd99bfcc885db127e (patch)
treeeac55bbdc379d6bec2af79db40e2320f1af1b82e
parent47fac5dc59c481e1ffc442f80e46ad7f8df4965b (diff)
gnu: bootstrap: Remove bootstrap-mescc-tools.
* gnu/packages/bootstrap.scm (%bootstrap-mescc-tools): Remove.
-rw-r--r--gnu/packages/bootstrap.scm52
1 files changed, 1 insertions, 51 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 03242f0e7b..820aaaa1cc 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018, 2020, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019 Carl Dong <contact@carldong.me>
;;; Copyright © 2019 Léo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -60,7 +60,6 @@
%bootstrap-gcc
%bootstrap-glibc
%bootstrap-inputs
- %bootstrap-mescc-tools
%bootstrap-mes
%bootstrap-inputs-for-tests))
@@ -932,55 +931,6 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(home-page #f)
(license gpl3+)))
-(define %bootstrap-mescc-tools
- ;; The initial MesCC tools. Uses binaries from a tarball typically built by
- ;; %MESCC-TOOLS-BOOTSTRAP-TARBALL.
- (package
- (name "bootstrap-mescc-tools")
- (version "0.5.2")
- (source #f)
- (build-system trivial-build-system)
- (arguments
- `(#:guile ,%bootstrap-guile
- #:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils)
- (ice-9 popen))
- (let ((out (assoc-ref %outputs "out"))
- (tar (assoc-ref %build-inputs "tar"))
- (xz (assoc-ref %build-inputs "xz"))
- (tarball (assoc-ref %build-inputs "tarball")))
-
- (mkdir out)
- (copy-file tarball "binaries.tar.xz")
- (invoke xz "-d" "binaries.tar.xz")
- (let ((builddir (getcwd))
- (bindir (string-append out "/bin")))
- (with-directory-excursion out
- (invoke tar "xvf"
- (string-append builddir "/binaries.tar"))))))))
- (inputs
- `(("tar" ,(bootstrap-executable "tar" (%current-system)))
- ("xz" ,(bootstrap-executable "xz" (%current-system)))
- ("tarball"
- ,(bootstrap-origin
- (origin
- (method url-fetch)
- (uri (map
- (cute string-append <>
- "/i686-linux/20190815/"
- "mescc-tools-static-stripped-0.5.2-i686-linux.tar.xz")
- %bootstrap-base-urls))
- (sha256
- (base32
- "0c3kklgghzh4q2dbpl6asb74cimp7hp6jscdwqwmzxbapgcl6582")))))))
- (synopsis "Bootstrap binaries of MesCC Tools")
- (description synopsis)
- (home-page #f)
- (supported-systems '("i686-linux" "x86_64-linux"))
- (license gpl3+)))
-
(define %bootstrap-mes
;; The initial Mes. Uses binaries from a tarball typically built by
;; %MES-BOOTSTRAP-TARBALL.