summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-13 13:06:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-14 10:59:03 +0200
commit19122da25de6808b5e9ddfb2785a0bec4b7cb3d4 (patch)
tree4a334cbc1bf2808beef5c2bf5659ad7b92f32b92
parent63b0d8912d1ab0fe29fedca72ef7435e8e78ceea (diff)
fixup gcc-core-mesboot0
(%current-system) evaluated too early
-rw-r--r--gnu/packages/commencement.scm63
1 files changed, 34 insertions, 29 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d3fc24611e..878ab35694 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1024,33 +1024,33 @@ MesCC-Tools), and finally M2-Planet.")
;; library, such as dir.h/struct DIR/readdir, locales, signals... Also,
;; with gcc-2.95.3, binutils (2.14.0, 2.20.1a) and glibc-2.2.5 we found a
;; GNU toolchain triplet "that works".
- (let ((triplet (match (%current-system)
- ((or "armhf-linux" "aarch64-linux")
- "arm-unknown-linux-gnu")
- ((or "i686-linux" "x86_64-linux")
- "i686-unknown-linux-gnu"))))
- (package
- (inherit gcc)
- (name "gcc-core-mesboot0")
- (version "2.95.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/gcc/gcc-2.95.3/gcc-core-"
- version
- ".tar.gz"))
- ;; `patches' needs XZ
- ;; (patches (search-patches "gcc-boot-2.95.3.patch"))
- (sha256
- (base32
- "1xvfy4pqhrd5v2cv8lzf63iqg92k09g6z9n2ah6ndd4h17k1x0an"))))
- (supported-systems '("armhf-linux" "aarch64-linux"
- "i686-linux" "x86_64-linux"))
- (inputs '())
- (propagated-inputs '())
- (native-inputs `(("binutils" ,binutils-mesboot0)
- ,@(%boot-tcc-inputs)))
- (outputs '("out"))
- (arguments
+ (package
+ (inherit gcc)
+ (name "gcc-core-mesboot0")
+ (version "2.95.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-2.95.3/gcc-core-"
+ version
+ ".tar.gz"))
+ ;; `patches' needs XZ
+ ;; (patches (search-patches "gcc-boot-2.95.3.patch"))
+ (sha256
+ (base32
+ "1xvfy4pqhrd5v2cv8lzf63iqg92k09g6z9n2ah6ndd4h17k1x0an"))))
+ (supported-systems '("armhf-linux" "aarch64-linux"
+ "i686-linux" "x86_64-linux"))
+ (inputs '())
+ (propagated-inputs '())
+ (native-inputs `(("binutils" ,binutils-mesboot0)
+ ,@(%boot-tcc-inputs)))
+ (outputs '("out"))
+ (arguments
+ (let ((triplet (match (%current-system)
+ ((or "armhf-linux" "aarch64-linux")
+ "arm-unknown-linux-gnu")
+ ((or "i686-linux" "x86_64-linux")
+ "i686-unknown-linux-gnu"))))
(list #:implicit-inputs? #f
#:guile %bootstrap-guile
#:tests? #f
@@ -1142,8 +1142,13 @@ ac_cv_c_float_format='IEEE (little-endian)'
(invoke "ar" "x" (string-append tcc "/lib/tcc/libtcc1.a"))
(invoke "ar" "x" (string-append tcc "/lib/libc.a"))
(invoke "ar" "r" (string-append gcc-dir "/libc.a")
- "libc.o" "libtcc1.o")))))))
- (native-search-paths
+ "libc.o" "libtcc1.o"))))))))
+ (native-search-paths
+ (let ((triplet (match (%current-system)
+ ((or "armhf-linux" "aarch64-linux")
+ "arm-unknown-linux-gnu")
+ ((or "i686-linux" "x86_64-linux")
+ "i686-unknown-linux-gnu"))))
(list (search-path-specification
(variable "C_INCLUDE_PATH")
(files `("include"