summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-09-12 10:54:31 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-14 19:43:37 +0200
commit48856c22a3ab20aa2d83b85bece26b917ec2fb26 (patch)
tree18f9fee2f935d87ce4060c8971a501d716044baa
parent4f52bf98f8066cced86323d912d3c4e0387c2864 (diff)
DRAFT gnu: bootstrap: mes-minimal: Remove packages and tarball.
* gnu/packages/make-bootstrap.scm (%mes-minimal, %mes-minimal-stripped, %mes-bootstrap-tarball): Remove.
-rw-r--r--gnu/packages/make-bootstrap.scm54
1 files changed, 0 insertions, 54 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 53da8896fb..e9ddb25d83 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -53,7 +53,6 @@
%glibc-bootstrap-tarball
%gcc-bootstrap-tarball
%guile-bootstrap-tarball
- %mes-bootstrap-tarball
%bootstrap-tarballs
%guile-static-stripped))
@@ -590,55 +589,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"--version"))
'("gcc" "g++" "cpp"))))))))))
-;; Two packages: first build static, bare minimum content.
-(define-public %mes-minimal
- ;; A minimal Mes without documentation.
- (package
- (inherit mes)
- (name "mes-minimal")
- (native-inputs (list guile-3.0))
- (arguments
- `(#:system "i686-linux"
- #:strip-binaries? #f
- #:configure-flags '("--mes")
- #:phases
- (modify-phases %standard-phases
- (delete 'patch-shebangs)
- (add-after 'install 'strip-install
- (lambda _
- (let* ((out (assoc-ref %outputs "out"))
- (share (string-append out "/share")))
- (delete-file-recursively (string-append out "/lib/guile"))
- (delete-file-recursively (string-append share "/guile"))
-
- (for-each delete-file
- (find-files
- (string-append share "/mes/lib")
- "\\.(h|c)"))))))))))
-
-;; next remove store references.
-(define %mes-minimal-stripped
- ;; A minimal Mes with store references removed, for bootstrap.
- (package
- (inherit %mes-minimal)
- (name (string-append (package-name %mes-minimal) "-stripped"))
- (build-system trivial-build-system)
- (arguments
- (list #:modules '((guix build utils))
- #:allowed-references '()
- #:builder
- #~(begin
- (use-modules (guix build utils))
- (let ((in #$%mes-minimal)
- (out #$output))
-
- (copy-recursively in out)
- (for-each (lambda (dir)
- (for-each remove-store-references
- (find-files (string-append out "/" dir)
- ".*")))
- '("bin" "share/mes"))))))))
-
(define* (make-guile-static guile patches)
(package-with-relocatable-glibc
(static-package
@@ -820,10 +770,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A tarball with the statically-linked, relocatable Guile.
(tarball-package %guile-static-stripped))
-(define %mes-bootstrap-tarball
- ;; A tarball with Mes binary seed.
- (tarball-package %mes-minimal-stripped))
-
(define %bootstrap-tarballs
;; A single derivation containing all the bootstrap tarballs, for
;; convenience.