summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-02-20 23:17:13 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-19 07:36:16 +0200
commit61f5bd8cf016862eb103993415511067b8e2353e (patch)
tree3180895bebbfc16c14fffc3ff41f9ae5dbdd5296
parentb7a8cc315477a6b00843053c2ad183c83afca022 (diff)
gnu: bootstrap: linux-libre-headers-bootstrap: Support ARM.
* gnu/packages/bootstrap.scm (%bootstrap-linux-libre-headers): Add tarball for armhf-linux.
-rw-r--r--gnu/packages/bootstrap.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 11cc8fbef9..491e4ca9ee 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -659,12 +659,23 @@ $out/bin/guile --version~%"
(origin
(method url-fetch)
(uri (map (cute string-append <>
- "/i686-linux/20190815/"
- "linux-libre-headers-stripped-4.14.67-i686-linux.tar.xz")
+ (match system
+ ((or "armhf-linux" "aarch64-linux")
+ (string-append
+ "/armhf-linux/20201219/"
+ "linux-libre-headers-stripped-5.4.20-armhf-linux.tar.xz"))
+ ((or "i686-linux" "x86_64-linux")
+ (string-append
+ "/i686-linux/20190815/"
+ "linux-libre-headers-stripped-4.14.67-i686-linux.tar.xz"))))
%bootstrap-base-urls))
(sha256
(base32
- "0sm2z9x4wk45bh6qfs94p0w1d6hsy6dqx9sw38qsqbvxwa1qzk8s"))))
+ (match system
+ ((or "armhf-linux" "aarch64-linux")
+ "0d010sp3n2q6cc3ppcgrxrdlgkgr3vlv3x76wz14gc3xfhnnm2x5")
+ ((or "i686-linux" "x86_64-linux")
+ "0sm2z9x4wk45bh6qfs94p0w1d6hsy6dqx9sw38qsqbvxwa1qzk8s"))))))
#f ; no program to test
"Bootstrap linux-libre-headers"))