summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-12-13 22:47:18 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-15 11:02:30 +0200
commita7e7f2909019e5b00734e5316261df097a9549aa (patch)
tree0ffb2ddc893b51c64ba61a5d78f6ebf75051afbe
parent83ddbe047721bca19db39b358a3fc45e1e79236f (diff)
gnu: bootstrap: mescc-tools: Support ARM.
* gnu/packages/make-bootstrap.scm[arguments]: Support armhf-linux, aarch64-linux. Update make-flags to really build static.
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 4ea97368a9..152b070c67 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -598,10 +598,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inherit mescc-tools)
(name "mescc-tools-static")
(arguments
- `(#:system "i686-linux"
+ `(#:system ,(match (%current-system)
+ ((or "i686-linux" "x86_64-linux") "i686-linux")
+ ((or "armhf-linux" "aarch64-linux") "armhf-linux"))
,@(substitute-keyword-arguments (package-arguments mescc-tools)
((#:make-flags flags)
- `(cons "CC=gcc -static" ,flags)))))))
+ '(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc -static")))))))
;; ... next remove store references.
(define %mescc-tools-static-stripped