summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-12-15 19:39:24 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-18 22:59:58 +0200
commitba4fb0c975ee90a8b5a5101509acf50103ce2cb1 (patch)
tree6a3ee4f740280acbd6024f9ec341947b9543e1a4
parent2c6136b6e3914323fcab1368d7dc2e3a035c1473 (diff)
gnu: commencement: mes-boot: Support ARM, update to 0.23.1.
* gnu/packages/commencement.scm (mes-boot)[source]: Update to 0.23.1. [native-inputs]: Upadate to nyacc-1.00.2. [arguments]: Cater for armhf-linux, aarch64-linux. [supported-systems]: Add arm-linux, aarch64-linux.
-rw-r--r--gnu/packages/commencement.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4d7222c2af..2fe6d8b337 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -399,22 +399,24 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(package
(inherit mes)
(name "mes-boot")
- (version "0.22")
+ (version "0.23.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mes/"
"mes-" version ".tar.gz"))
(sha256
(base32
- "0p1jsrrmcbc0zrvbvnjbb6iyxr0in71km293q8qj6gnar6bw09av"))))
+ "0hbnqgjiajs8wq03dkvr9aswrzk8kl98dm6245xhlgqis8d2yhqd"))))
(inputs '())
(propagated-inputs '())
(native-inputs
- `(("nyacc-source" ,(origin (inherit (package-source nyacc-0.99))
+ `(("nyacc-source" ,(origin (inherit (package-source nyacc-1.00.2))
(snippet #f)))
("mes" ,%bootstrap-mes-rewired)
("mescc-tools" ,%bootstrap-mescc-tools)
,@(%boot-gash-inputs)))
+ (supported-systems '("armhf-linux" "aarch64-linux"
+ "i686-linux" "x86_64-linux"))
(arguments
`(#:implicit-inputs? #f
#:tests? #f
@@ -439,10 +441,14 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(setenv "GUILE_LOAD_PATH"
(string-append
mes "/share/mes/module"
- ":" dir "/nyacc-0.99.0/module"))
+ ":" dir "/nyacc-1.00.2/module"))
(invoke "gash" "configure.sh"
(string-append "--prefix=" out)
- (string-append "--host=i686-linux-gnu")))))
+ (string-append ,(match (%current-system)
+ ((or "armhf-linux" "aarch64-linux")
+ "--host=arm-linux")
+ ((or "i686-linux" "x86_64-linux")
+ "--host=i686-linux-gnu")))))))
(replace 'build
(lambda _
(invoke "sh" "bootstrap.sh")))
@@ -479,7 +485,6 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(separator #f)
(files '("")))))))
-
(define tcc-boot0
;; Pristine tcc cannot be built by MesCC, we are keeping a delta of 11
;; patches. In a very early and rough form they were presented to the