summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-09-01 11:22:52 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-01 22:24:48 +0200
commit97ce5964fb5d52cf2151fea685e28fa23a98b264 (patch)
treee7acaa83a71e0b296d6928f24af56ed247ed15fc
parent37c08f42f7551203e98384c13ecfd33b57df40e6 (diff)
gnu: ironclad: Update to 0.46.
* gnu/packages/lisp.scm (sbcl-ironclad): Update to 0.46. [source]: Fix file-name. [inputs]: Add bordeaux-threads dependency. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lisp.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ab1c84262e..72587f2925 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2175,7 +2175,7 @@ also be supported.")
(define-public sbcl-ironclad
(package
(name "sbcl-ironclad")
- (version "0.42")
+ (version "0.46")
(source
(origin
(method git-fetch)
@@ -2184,14 +2184,15 @@ also be supported.")
(commit (string-append "v" version))))
(sha256
(base32
- "1wjcb9vpybxjrmch7f7s78a5abxmnknbd4fl49dl5lz8a3fc8vf0"))
- (file-name (string-append "ironblad" version "-checkout"))))
+ "1s391awi2lsl7m1dbjirgpkm4p9p8wd076pakgvsvpn1rrznisnd"))
+ (file-name (git-file-name name version))))
(build-system asdf-build-system/sbcl)
(native-inputs
;; Tests only.
`(("rt" ,sbcl-rt)))
(inputs
- `(("flexi-streams" ,sbcl-flexi-streams)
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("flexi-streams" ,sbcl-flexi-streams)
("nibbles" ,sbcl-nibbles)))
(synopsis "Cryptographic toolkit written in Common Lisp")
(description