summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-09-03 02:49:52 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-09-03 02:49:52 +0200
commitc94dc299137742e4e1a87572cd7b866d6510bc6f (patch)
tree265593a3509b75086d5570b35ef51265e9277dc7
parent9112c78af5ed872f25f7d01a8d7553a3778ea25f (diff)
gnu: Add buildroot-boards.
* gnu/packages/buildroot.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/buildroot.scm66
2 files changed, 67 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index dbae857c38..3e334a94bb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -95,6 +95,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/bootloaders.scm \
%D%/packages/bootstrap.scm \
%D%/packages/build-tools.scm \
+ %D%/packages/buildroot.scm \
%D%/packages/busybox.scm \
%D%/packages/c.scm \
%D%/packages/calcurse.scm \
diff --git a/gnu/packages/buildroot.scm b/gnu/packages/buildroot.scm
new file mode 100644
index 0000000000..31e2a73ad9
--- /dev/null
+++ b/gnu/packages/buildroot.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 nee <nee@cock.li>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages bootloaders)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (ice-9 regex))
+
+(define-public buildroot-boards
+ (package
+ (name "buildroot-boards")
+ (version "2019.02.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://buildroot.org/downloads/buildroot-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "08cn7jd23kfd0g5sh8gzskn3s0ix27kvsr3r9i4vns1yz53zmi6g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((destination (string-append (assoc-ref outputs "out")
+ "/share/buildroot/board")))
+ (copy-recursively "board" destination))
+ #t)))))
+ (synopsis "Generate embedded Linux system images")
+ (description "@code{buildroot} generates embedded Linux system images.")
+ (home-page "https://github.com/buildroot/buildroot")
+ (license license:gpl2+)))