summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-15 04:38:42 -0500
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commit13edb0e5c36181bc8a48fa6a28005b3e3046174a (patch)
tree5ba57967e351856f16cec61db7654012289b2098
parent25a7db0ad32d0863fbb648a93699b034bd9fce0b (diff)
gnu: Add python2-unicodecsv.
* gnu/packages/python.scm (python2-unicodecsv): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4ea2064df6..75481fc5b6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8411,3 +8411,30 @@ encoding algorithms to do fuzzy string matching.")
(native-inputs `(("python2-setuptools" ,python2-setuptools)
("python2-unicodecsv" ,python2-unicodecsv)
,@(package-native-inputs jellyfish))))))
+
+(define-public python2-unicodecsv
+ (package
+ (name "python2-unicodecsv")
+ (version "0.14.1")
+ (source (origin
+ (method url-fetch)
+ ;; The test suite is not included in the PyPi release.
+ ;; https://github.com/jdunck/python-unicodecsv/issues/19
+ (uri (string-append "https://github.com/jdunck/python-unicodecsv/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "087nqanfcyp6mlfbbr5lva5f3w6iz1bybls9xlrb8icmc474wh4w"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; It supports Python 3, but Python 3 can already do Unicode CSV.
+ #:python ,python-2))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unittest2" ,python2-unittest2)))
+ (home-page "https://github.com/jdunck/python-unicodecsv")
+ (synopsis "Unicode CSV module for Python 2")
+ (description "Unicodecsv is a drop-in replacement for Python 2.7's CSV
+module, adding support for Unicode strings.")
+ (license bsd-2)))