summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-15 04:36:37 -0500
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commit25a7db0ad32d0863fbb648a93699b034bd9fce0b (patch)
tree0f245825673f59b7aca1f66ea96f7b91f691cb1c
parentefe0b14369106561ae13a5de270fb922415c6237 (diff)
gnu: Add python-jellyfish.
* gnu/packages/python.scm (python-jellyfish, python2-jellyfish): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cff82fa198..4ea2064df6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8383,3 +8383,31 @@ ambiguities (forward vs. backward slashes, etc.).
(define-public python2-pathlib
(package-with-python2 python-pathlib))
+
+(define-public python-jellyfish
+ (package
+ (name "python-jellyfish")
+ (version "0.5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jellyfish" version))
+ (sha256
+ (base32
+ "12bxh8cy9xmvyrjz7aw159nd5pyvb645rkvw4r6bvm4xbvs8gd07"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/jamesturk/jellyfish")
+ (synopsis "Approximate and phonetic matching of strings")
+ (description "Jellyfish uses a variety of string comparison and phonetic
+encoding algorithms to do fuzzy string matching.")
+ (license bsd-2)
+ (properties `((python2-variant . ,(delay python2-jellyfish))))))
+
+(define-public python2-jellyfish
+ (let ((jellyfish (package-with-python2
+ (strip-python2-variant python-jellyfish))))
+ (package (inherit jellyfish)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unicodecsv" ,python2-unicodecsv)
+ ,@(package-native-inputs jellyfish))))))