summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-19 15:57:07 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-19 15:57:07 +0100
commit329a702634ec9b12f41676fb7b0680f0797f5907 (patch)
treefaeffd44c8dbc226f3355c7562236d6ea3b3e7bf
parent56586557ddb0fb6073afbc276cb92e08ce063dad (diff)
gnu: fontforge: Make builds bit-reproducible.
* gnu/packages/fontutils.scm (fontforge)[source](snippet, modules): New fields.
-rw-r--r--gnu/packages/fontutils.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1fcd173477..01a0ee7c36 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -360,7 +360,17 @@ definitions.")
"https://github.com/fontforge/fontforge/releases/download/"
version "/fontforge-" version ".tar.gz"))
(sha256 (base32
- "0gfcm8yn1d30giqhdwbchnfnspcqypqdzrxlhqhwy1i18wgl0v2v"))))
+ "0gfcm8yn1d30giqhdwbchnfnspcqypqdzrxlhqhwy1i18wgl0v2v"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Make builds bit-reproducible by using fixed date strings.
+ '(substitute* "configure"
+ (("^FONTFORGE_MODTIME=.*$")
+ "FONTFORGE_MODTIME=\"1458399002\"\n")
+ (("^FONTFORGE_MODTIME_STR=.*$")
+ "FONTFORGE_MODTIME_STR=\"15:50 CET 19-Mar-2016\"\n")
+ (("^FONTFORGE_VERSIONDATE=.*$")
+ "FONTFORGE_VERSIONDATE=\"20160319\"\n")))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))