summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-20 23:01:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-03-21 22:08:24 +0100
commit416a5a9a51c96ebc6d0d04be62fa3e9611321294 (patch)
tree5e3a0680410786733b20fc0176ad01c5b003c7d7
parentacb380707937285bb9a9535ca4bab0b9d96e6574 (diff)
gnu: chicken: Disable port tests.
* gnu/packages/scheme.scm (chicken)[arguments]: Do not run port tests.
-rw-r--r--gnu/packages/scheme.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index cb113e8d9c..b8b2dbacab 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -331,7 +331,14 @@ mashups, office (web agendas, mail clients, ...), etc.")
(delete 'configure)
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check)))
+ (assoc-ref %standard-phases 'check))
+ (add-after 'unpack 'disable-broken-tests
+ (lambda _
+ ;; The port tests fail with this error:
+ ;; Error: (line 294) invalid escape-sequence '\x o'
+ (substitute* "tests/runtests.sh"
+ (("\\$interpret -s port-tests\\.scm") ""))
+ #t)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "PLATFORM=linux"