summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochem Raat <jchmrt@riseup.net>2016-03-16 14:12:08 +0100
committerLeo Famulari <leo@famulari.name>2016-03-17 00:39:33 -0400
commit65829fec471707d38700573a25eb88e5ef17ff3f (patch)
tree481e7677a1a2e6ee2c1e0eae82c4428c7e1275b4
parent08e9daf505eb41d8831bbd36e77ecebf3acd4ebc (diff)
gnu: Add perl-text-neattemplate.
* gnu/packages/perl.scm (perl-text-neattemplate): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d67870f462..fb42735495 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5695,6 +5696,31 @@ used to match against text, rather than fetching names from a filesystem. If
you want to do full file globbing use the File::Glob module instead.")
(license (package-license perl))))
+(define-public perl-text-neattemplate
+ (package
+ (name "perl-text-neattemplate")
+ (version "0.1101")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://cpan.metacpan.org/authors/id/R/RU/RUBYKAT/"
+ "Text-NeatTemplate-" version ".tar.gz"))
+ (sha256
+ (base32
+ "129msa57jzxxi2x7z9hgzi48r48y65w77ycfk1w733zz2m8nr8y3"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "http://search.cpan.org/dist/Text-NeatTemplate")
+ (synopsis "Fast, middleweight template engine")
+ (description
+ "Text::NeatTemplate provides a simple, middleweight but fast
+template engine, for when you need speed rather than complex features,
+yet need more features than simple variable substitution.")
+ (license (package-license perl))))
+
(define-public perl-text-simpletable
(package
(name "perl-text-simpletable")