summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-20 17:10:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-03-21 22:08:24 +0100
commitacb380707937285bb9a9535ca4bab0b9d96e6574 (patch)
tree5d0bbbad3f10bba7087a495e54389228a1968323
parentd0d941101567e652981d47ab96131d20dd354e76 (diff)
gnu: chicken: Use "modify-phases" syntax.
* gnu/packages/scheme.scm (chicken)[arguments]: Use "modify-phases" syntax.
-rw-r--r--gnu/packages/scheme.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 5361f23e59..cb113e8d9c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -326,11 +326,12 @@ mashups, office (web agendas, mail clients, ...), etc.")
;; No `configure' script; run "make check" after "make install" as
;; prescribed by README.
- #:phases (alist-cons-after
- 'install 'check
- (assoc-ref %standard-phases 'check)
- (fold alist-delete %standard-phases
- '(configure check)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "PLATFORM=linux"