summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 15:57:09 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:15 -0500
commitbecb7c9987518a738950b5c40cce6456d928616a (patch)
tree7a61e346ced2d0eb96abff4db3006cc0f47f9533
parent3ee26f989cb626d26a125314ed0f94bbd6ce330a (diff)
gnu: xf86-video-glint: Update to 1.2.8.
* gnu/packages/patches/xf86-video-glint-remove-mibstore.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-glint): Update to 1.2.8. Add patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-glint-remove-mibstore.patch24
-rw-r--r--gnu/packages/xorg.scm8
3 files changed, 30 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 88fa47945b..da561a5548 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -461,6 +461,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
+ gnu/packages/patches/xf86-video-glint-remove-mibstore.patch \
gnu/packages/patches/xf86-video-openchrome-includes.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch
diff --git a/gnu/packages/patches/xf86-video-glint-remove-mibstore.patch b/gnu/packages/patches/xf86-video-glint-remove-mibstore.patch
new file mode 100644
index 0000000000..969ed7e41e
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-glint-remove-mibstore.patch
@@ -0,0 +1,24 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-glint-1.2.8/src/glint_driver.c.~1~ 2012-07-15 22:50:47.000000000 -0400
++++ xf86-video-glint-1.2.8/src/glint_driver.c 2014-12-19 00:42:39.162714279 -0500
+@@ -52,8 +52,6 @@
+ #include "compiler.h"
+ #include "mipointer.h"
+
+-#include "mibstore.h"
+-
+ #include "pm3_regs.h"
+ #include "glint_regs.h"
+ #include "IBM.h"
+@@ -2904,7 +2902,6 @@
+ }
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4fc99f4bc0..01e365585e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2534,17 +2534,19 @@ devices, thus making direct access unnecessary.")
(define-public xf86-video-glint
(package
(name "xf86-video-glint")
- (version "1.2.7")
+ (version "1.2.8")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-glint-"
+ "mirror://xorg/individual/driver/xf86-video-glint-"
version
".tar.bz2"))
(sha256
(base32
- "0nf36jryabpncqq4m6sfsnmzk00f7gvfmjnl8l8sfy7w6sa6iacs"))))
+ "08a2aark2yn9irws9c78d9q44dichr03i9zbk61jgr54ncxqhzv5"))
+ (patches (list
+ (search-patch "xf86-video-glint-remove-mibstore.patch")))))
(build-system gnu-build-system)
(inputs `(("xf86dgaproto" ,xf86dgaproto)
("xorg-server" ,xorg-server)))