summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-23 06:34:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-03-23 08:08:02 +0100
commitc1f73569beb5297d338c2586bdfce3279db49e7f (patch)
treed54f877363b5da7bccbad10e5daa51c99bee7449
parent6139fed5630de3e4d8fd8281fcc0ab4d7b66b808 (diff)
gnu: Add AIDE.
* gnu/packages/admin.scm (aide): New variable.
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 69802e9a36..76187ae921 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages glib)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages mcrypt)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages texinfo)
@@ -66,6 +67,37 @@
#:use-module (gnu packages man)
#:use-module (gnu packages autotools))
+(define-public aide
+ (package
+ (name "aide")
+ (version "0.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/aide/aide/"
+ version "/aide-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vsrc0s62kv1i84skm6k6zy868gayjck268qwj38rpspc8c5qgih"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("libgpg-error" ,libgpg-error)
+ ("libmhash" ,libmhash)
+ ("zlib" ,zlib)))
+ (synopsis "File and directory integrity checker")
+ (description
+ "AIDE (Advanced Intrusion Detection Environment) is a file and directory
+integrity checker. It creates a database from the regular expression rules
+that it finds from its configuration files. Once this database is initialized
+it can be used to verify the integrity of the files. It has several message
+digest algorithms that are used to check the integrity of files. All of the
+usual file attributes can be checked for inconsistencies.")
+ (home-page "http://aide.sourceforge.net/")
+ (license license:gpl2+)))
+
(define-public dmd
;; Deprecated. Kept around "just in case."
(let ((base-version "0.2")