summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-20 23:03:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-03-21 22:08:24 +0100
commitffc13e753b37adb694de1d26f3ea51cf0796a8a2 (patch)
tree39259a8dab424af4c3e3d2952ad98f6d8323017a
parent416a5a9a51c96ebc6d0d04be62fa3e9611321294 (diff)
gnu: chicken: Build with GCC 4.8.
* gnu/packages/scheme.scm (chicken)[native-inputs]: Add GCC 4.8.
-rw-r--r--gnu/packages/scheme.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b8b2dbacab..f16629397f 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages avahi)
#:use-module (gnu packages libphidget)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
@@ -347,6 +348,12 @@ mashups, office (web agendas, mail clients, ...), etc.")
;; Parallel builds are not supported, as noted in README.
#:parallel-build? #f))
+ ;; One of the tests ("testing direct invocation can detect calls of too
+ ;; many arguments...") times out when building with a more recent GCC.
+ ;; The problem was reported here:
+ ;; https://lists.gnu.org/archive/html/chicken-hackers/2015-04/msg00059.html
+ (native-inputs
+ `(("gcc" ,gcc-4.8)))
(home-page "http://www.call-cc.org/")
(synopsis "R5RS Scheme implementation that compiles native code via C")
(description