summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-16 22:09:56 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:13 -0500
commit1846b423e29571a20733999b14b59511ab367469 (patch)
treef9af0b54b79c329561303d3b056cc0cbf43951af
parenta29bfc28f0cba425d060d5b36363eb6e723c60c9 (diff)
gnu: Add Config-General.
* gnu/packages/perl.scm (perl-config-general): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fdb1c823f2..e1eb0887bc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -682,6 +682,30 @@ supports XML, YAML, JSON, Apache-style configuration, and Perl code.")
opportunities to Perl developers as GNU Autoconf does for Shell developers.")
(license (package-license perl))))
+(define-public perl-config-general
+ (package
+ (name "perl-config-general")
+ (version "2.56")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TL/TLINDEN/"
+ "Config-General-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0szxxaihz71pr0r2jp9wvbrfc3hrsxi9xrd9vnyrxlrax8sci5h9"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Config-General")
+ (synopsis "Generic Config Module")
+ (description "This module opens a config file and parses its contents for
+you. The format of config files supported by Config::General is inspired by
+the well known Apache config format and is 100% compatible with Apache
+configs, but you can also just use simple name/value pairs in your config
+files. In addition to the capabilities of an Apache config file it supports
+some enhancements such as here-documents, C-style comments, and multiline
+options.")
+ (license (package-license perl))))
+
(define-public perl-context-preserve
(package
(name "perl-context-preserve")