summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 11:09:43 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit1f477b59c1b8167d2bd347ef81f02e728bbbf869 (patch)
treecb7c5c70a97667c702660778afa7472e0431c75d
parent5e217e4df7441d8a21acc96b6265acce05666f51 (diff)
gnu: Add ghc-cgi.
* gnu/packages/haskell.scm (ghc-cgi): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 54271d864f..175d026e43 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -547,6 +547,37 @@ module containing code for scanning text efficiently. It is similar to the
tool lex or flex for C/C++.")
(license bsd-3)))
+(define-public ghc-cgi
+ (package
+ (name "ghc-cgi")
+ (version "3001.2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/cgi/cgi-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0q1pxpa8gi42c0hsidcdkhk5xr5anfrvhqsn3iksr9c0rllhz193"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-parsec" ,ghc-parsec)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-old-time" ,ghc-old-time)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-multipart" ,ghc-multipart)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-network" ,ghc-network)
+ ("ghc-mtl" ,ghc-mtl)))
+ (home-page
+ "https://github.com/cheecheeo/haskell-cgi")
+ (synopsis "Library for writing CGI programs")
+ (description
+ "This is a Haskell library for writing CGI programs.")
+ (license bsd-3)))
+
(define-public ghc-cmdargs
(package
(name "ghc-cmdargs")