summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 15:19:25 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit32ce3df7584c8a0536ba09797ae8c087c7998719 (patch)
tree836c6a6ea7ea4dacab7d91a2d05ae2c947215833
parent766504d19996eb531a542cf8b2ef7ade0e737e91 (diff)
gnu: Add ghc-tasty-quickcheck.
* gnu/packages/haskell.scm (ghc-tasty-quickcheck): New variable.
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bebeda52c6..be9c76d60b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2831,6 +2831,35 @@ functions for breaking or splitting on substrings and replacing all
occurrences of a substring (the first in case of overlaps) with another.")
(license bsd-3)))
+(define-public ghc-tasty-quickcheck
+ (package
+ (name "ghc-tasty-quickcheck")
+ (version "0.8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/tasty-quickcheck/"
+ "tasty-quickcheck-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rjxib5jmjq0hzj47x15kgp3awc73va4cy1pmpf7k3hvfv4qprn"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (inputs
+ `(("ghc-tagged" ,ghc-tagged)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-random" ,ghc-random)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-pcre-light" ,ghc-pcre-light)))
+ (home-page "http://documentup.com/feuerbach/tasty")
+ (synopsis "QuickCheck support for the Tasty test framework")
+ (description "This package provides QuickCheck support for the Tasty
+Haskell test framework.")
+ (license expat)))
+
(define-public ghc-tasty
(package
(name "ghc-tasty")