summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:57:25 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit3f2ce1dc3f070bb1cc24616cd56b3ab66b67af80 (patch)
tree98f0b3b62e7aff78c85104a4f88211a294025a1a
parentfa709a2fc9e5ebc98df9d61452c727283a05fcd8 (diff)
gnu: Add ghc-clock-bootstrap.
The ghc-clock-bootstrap package has tests disabled, since they themselves indirectly require ghc-clock. After adding ghc-tasty and ghc-tasty-quickcheck, ghc-clock is defined as a public package with tests enabled. * gnu/packages/haskell.scm (ghc-clock-bootstrap): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8fb9844f09..b8d2e0ad7c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2410,6 +2410,31 @@ or timeout period. This package provides alternative functions which use the
unbounded @code{Integer} type.")
(license bsd-3)))
+;; This package builds `clock` without tests, since the tests rely on tasty
+;; and tasty-quickcheck, which in turn require clock to build. When tasty and
+;; tasty-quickcheck are added, we will add ghc-clock with tests enabled.
+(define ghc-clock-bootstrap
+ (package
+ (name "ghc-clock-bootstrap")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/"
+ "clock/"
+ "clock-" version ".tar.gz"))
+ (sha256
+ (base32 "1ncph7vi2q6ywwc8ysxl1ibw6i5dwfvln88ssfazk8jgpj4iyykw"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ;; Testing suite depends on tasty and
+ ;; tasty-quickcheck, which need clock to build.
+ (home-page "https://hackage.haskell.org/package/clock")
+ (synopsis "High-resolution clock for Haskell")
+ (description "A package for convenient access to high-resolution clock and
+timer functions of different operating systems via a unified API.")
+ (license bsd-3)))
+
(define-public ghc-charset
(package
(name "ghc-charset")