summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 17:06:03 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit5125f63fea0dccf4e620a81e73636ad8e2a30067 (patch)
treed35e03cce6e62dfe4d5055c8d74148587746f1ba
parent576cdc5ab4c6f08048db2f3a7a4aeae663594a17 (diff)
gnu: Add ghc-kan-extensions.
* gnu/packages/haskell.scm (ghc-kan-extensions): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 97c61be9d4..a35ba5c44b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3336,6 +3336,37 @@ Compatibility package for older packages.")
given term should not exist.")
(license bsd-3)))
+(define-public ghc-kan-extensions
+ (package
+ (name "ghc-kan-extensions")
+ (version "4.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/kan-extensions/kan-extensions-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0iywbadpy8s3isfzlx9dlz3apaywhqq4gdbxkwygksq8pzdhwkrk"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-adjunctions" ,ghc-adjunctions)))
+ (inputs
+ `(("ghc-comonad" ,ghc-comonad)
+ ("ghc-contravariant" ,ghc-contravariant)
+ ("ghc-distributive" ,ghc-distributive)
+ ("ghc-free" ,ghc-free)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)
+ ("ghc-tagged" ,ghc-tagged)))
+ (home-page "http://github.com/ekmett/kan-extensions/")
+ (synopsis "Kan extensions library")
+ (description "This library provides Kan extensions, Kan lifts, various
+forms of the Yoneda lemma, and (co)density (co)monads for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-statevar
(package
(name "ghc-statevar")