summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:49:08 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit52db0e13720f2281d3a7c9c6eb91990df73b4355 (patch)
treeeee9793197b5d34d1dce84d5d9d173786e13bee0
parentdc2e8ab7ea84bfc980bf8bbbf22f9265afab9297 (diff)
gnu: Add ghc-adjunctions.
* gnu/packages/haskell.scm (ghc-adjunctions): New variable.
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 599a50d3e3..f6536982ac 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3249,6 +3249,39 @@ f} makes no constraining assumptions beyond those given by @code{f} and the
definition of @code{Monad}.")
(license bsd-3)))
+(define-public ghc-adjunctions
+ (package
+ (name "ghc-adjunctions")
+ (version "4.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/adjunctions/adjunctions-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "00p030iypjzjib8pxz1x6mxfi59wvyrwjj11zv9bh766dgkdbwjq"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-profunctors" ,ghc-profunctors)))
+ (inputs
+ `(("ghc-comonad" ,ghc-comonad)
+ ("ghc-contravariant" ,ghc-contravariant)
+ ("ghc-distributive" ,ghc-distributive)
+ ("ghc-free" ,ghc-free)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-void" ,ghc-void)))
+ (home-page "http://github.com/ekmett/adjunctions/")
+ (synopsis "Adjunctions and representable functors")
+ (description "This library provides adjunctions and representable functors
+for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-fast-logger
(package
(name "ghc-fast-logger")