summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 10:59:00 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit56b3bc5694837c8558c007d4112ac16bf0fdd395 (patch)
tree496def639d0ce659f42f2423cfe5e33df8cfa239
parent600621a182efca965cea18bf869b463f7b40cb29 (diff)
gnu: Add ghc-haddock-library.
* gnu/packages/haskell.scm (ghc-haddock-library): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d8f8bede85..f47f3ac398 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -387,6 +387,36 @@ package.")
package.")
(license bsd-3)))
+(define-public ghc-haddock-library
+ (package
+ (name "ghc-haddock-library")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/haddock-library/haddock-library-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0mhh2ppfhrvvi9485ipwbkv2fbgj35jvz3la02y3jlvg5ffs1c8g"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://www.haskell.org/haddock/")
+ (synopsis
+ "Library exposing some functionality of Haddock")
+ (description
+ "Haddock is a documentation-generation tool for Haskell libraries. These
+modules expose some functionality of it without pulling in the GHC dependency.
+Please note that the API is likely to change so specify upper bounds in your
+project if you can't release often. For interacting with Haddock itself, see
+the ‘haddock’ package.")
+ (license bsd-3)))
+
(define-public ghc-simple-reflect
(package
(name "ghc-simple-reflect")