summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 15:20:46 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit5722409b182f1a0bae44e1b05a65306ba4480a09 (patch)
tree8f914448d0ede34056a526f7fa409a7a2e868956
parente372520ec3a6b6a091d12a82291d505c1bb9b5bd (diff)
gnu: Add ghc-cookie.
* gnu/packages/haskell.scm (ghc-cookie): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1aa39ea62d..a89e6f426b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3834,6 +3834,37 @@ and any other types of tests into a single test suite.")
test framework.")
(license expat)))
+(define-public ghc-cookie
+ (package
+ (name "ghc-cookie")
+ (version "0.4.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/cookie/cookie-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0b6ym6fn29p5az4dwydy036lxj131kagrmgb93w4bbkqfkds8b9s"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-old-locale" ,ghc-old-locale)))
+ (inputs
+ `(("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "http://github.com/snoyberg/cookie")
+ (synopsis "HTTP cookie parsing and rendering")
+ (description "HTTP cookie parsing and rendering library for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-scientific
(package
(name "ghc-scientific")