summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 17:04:39 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit576cdc5ab4c6f08048db2f3a7a4aeae663594a17 (patch)
tree1f75472c337403fe4dae1cd92978d1413d7feaa8
parent7588e55c737ff0091a170a158374a9c7819eccea (diff)
gnu: Add ghc-vector-binary-instances.
* gnu/packages/haskell.scm (ghc-vector-binary-instances): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9e95db0734..97c61be9d4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2519,6 +2519,34 @@ Int-indexed arrays (both mutable and immutable), with a powerful loop
optimisation framework.")
(license bsd-3)))
+(define-public ghc-vector-binary-instances
+ (package
+ (name "ghc-vector-binary-instances")
+ (version "0.2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/"
+ "vector-binary-instances/vector-binary-instances-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "028rsf2w193rhs1gic5yvvrwidw9sblczcn10aw64npfc6502l4l"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-cereal" ,ghc-cereal)))
+ (inputs
+ `(("ghc-vector" ,ghc-vector)))
+ (home-page "https://github.com/bos/vector-binary-instances")
+ (synopsis "Instances of Data.Binary and Data.Serialize for vector")
+ (description "This library provides instances of @code{Binary} for the
+types defined in the @code{vector} package, making it easy to serialize
+vectors to and from disk. We use the generic interface to vectors, so all
+vector types are supported. Specific instances are provided for unboxed,
+boxed and storable vectors.")
+ (license bsd-3)))
+
(define-public ghc-network
(package
(name "ghc-network")