summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:49:54 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit6729152dc5178d2af07658d6cf145d3657a09b14 (patch)
tree8de47006bee31920de3178d53662839e611fdf9d
parent52db0e13720f2281d3a7c9c6eb91990df73b4355 (diff)
gnu: Add ghc-simple-reflect.
* gnu/packages/haskell.scm (ghc-simple-reflect): New variable.
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f6536982ac..e23a3ee903 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -386,6 +386,33 @@ package.")
package.")
(license bsd-3)))
+(define-public ghc-simple-reflect
+ (package
+ (name "ghc-simple-reflect")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/simple-reflect/simple-reflect-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1dpcf6w3cf1sfl9bnlsx04x7aghw029glj5d05qzrsnms2rlw8iq"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://twanvl.nl/blog/haskell/simple-reflection-of-expressions")
+ (synopsis
+ "Simple reflection of expressions containing variables")
+ (description
+ "This package allows simple reflection of expressions containing
+variables. Reflection here means that a Haskell expression is turned into a
+string. The primary aim of this package is teaching and understanding; there
+are no options for manipulating the reflected expressions beyond showing
+them.")
+ (license bsd-3)))
+
(define-public ghc-reflection
(package
(name "ghc-reflection")