summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:39:24 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit6c1a7751a55617f43743529042e12e30bd1b4cd5 (patch)
tree50a44e7baaa53fc82e82af5c4d931bc3fd6b77b4
parent9e5224e6f3d7604db3f75e70e69fdf187ec510f3 (diff)
gnu: Add ghc-tagsoup.
* gnu/packages/haskell.scm (ghc-tagsoup): New variable.
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4a399ceb6d..2611727f37 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2456,6 +2456,35 @@ given term should not exist.")
in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
(license bsd-3)))
+(define-public ghc-tagsoup
+ (package
+ (name "ghc-tagsoup")
+ (version "0.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/tagsoup/tagsoup-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "13b6zy6346r3cxhaivys84fnxarg8wbv7r2znazfjdkqil8n5a1j"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-text" ,ghc-text)))
+ (home-page
+ "http://community.haskell.org/~ndm/tagsoup/")
+ (synopsis
+ "Parsing and extracting information from (possibly malformed) HTML/XML
+documents")
+ (description
+ "TagSoup is a library for parsing HTML/XML. It supports the HTML 5
+specification, and can be used to parse either well-formed XML, or
+unstructured and malformed HTML from the web. The library also provides
+useful functions to extract information from an HTML document, making it ideal
+for screen-scraping.")
+ (license bsd-3)))
+
(define-public ghc-digest
(package
(name "ghc-digest")