summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 15:06:02 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit6f5e312e977118cc6eff4195381263beec60dab3 (patch)
treea6b76f8e8e44b10dd9f7e1a680974b2d335e7675
parent34128d2ba78c305ea588c761255fbc06b7819f05 (diff)
gnu: Add ghc-lifted-base.
* gnu/packages/haskell.scm (ghc-lifted-base): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 16144db2a1..124c86fa2f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2730,4 +2730,35 @@ It is modeled after doctest for Python, see
@uref{http://docs.python.org/library/doctest.html, the Doctest website}.")
(license expat)))
+(define-public ghc-lifted-base
+ (package
+ (name "ghc-lifted-base")
+ (version "0.2.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/lifted-base/lifted-base-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1yz14a1rsgknwyl08n4kxrlc26hfwmb95a3c2drbnsgmhdyq7iap"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: Missing testing libraries.
+ (propagated-inputs
+ `(("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-monad-control" ,ghc-monad-control)))
+ (inputs
+ `(("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/basvandijk/lifted-base")
+ (synopsis "Lifted IO operations from the base library")
+ (description "Lifted-base exports IO operations from the @code{base}
+library lifted to any instance of @code{MonadBase} or @code{MonadBaseControl}.
+Note that not all modules from @code{base} are converted yet. The package
+includes a copy of the @code{monad-peel} test suite written by Anders
+Kaseorg.")
+ (license bsd-3)))
+
;;; haskell.scm ends here