summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 13:16:22 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit6ff19687b1b12822e86f85836c26aab9246ec713 (patch)
tree43cc6615cc473d50dff200b79e6f4be63aff08d5
parent81da1a45e80d9a71fb69d2e61ba5aab7dee4149d (diff)
gnu: Add ghc-haskell-src-exts.
* gnu/packages/haskell.scm (ghc-haskell-src-exts): New variable.
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 930df4a785..03c283b014 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -461,6 +461,39 @@ specification in BNF, Happy generates Haskell code to parse the grammar.
Happy works in a similar way to the yacc tool for C.")
(license bsd-3)))
+(define-public ghc-haskell-src-exts
+ (package
+ (name "ghc-haskell-src-exts")
+ (version "1.16.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/haskell-src-exts/haskell-src-exts-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1h8gjw5g92rvvzadqzpscg73x7ajvs1wlphrh27afim3scdd8frz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("cpphs" ,cpphs)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-smallcheck" ,ghc-smallcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-happy" ,ghc-happy)
+ ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-syb" ,ghc-syb)))
+ (home-page "https://github.com/haskell-suite/haskell-src-exts")
+ (synopsis "Library for manipulating Haskell source")
+ (description "Haskell-Source with Extensions (HSE, haskell-src-exts) is an
+extension of the standard @code{haskell-src} package, and handles most
+registered syntactic extensions to Haskell. All extensions implemented in GHC
+are supported. Apart from these standard extensions, it also handles regular
+patterns as per the HaRP extension as well as HSX-style embedded XML syntax.")
+ (license bsd-3)))
+
(define-public cpphs
(package
(name "cpphs")