summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 16:48:50 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit7588e55c737ff0091a170a158374a9c7819eccea (patch)
treeac41aff987784b1dbeb72923aa0c94b8a0e16c7d
parentfc3aa91b55fa79debb07591f3888e2e75ea5ff56 (diff)
gnu: Add ghc-wai-extra.
* gnu/packages/haskell.scm (ghc-wai-extra): New variable.
-rw-r--r--gnu/packages/haskell.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f9f7449609..9e95db0734 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4005,4 +4005,52 @@ communication between web applications and web servers.")
(description "This package provides the logging system for WAI.")
(license bsd-3)))
+(define-public ghc-wai-extra
+ (package
+ (name "ghc-wai-extra")
+ (version "3.0.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/wai-extra/wai-extra-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1kr2s5qyx1dvnwr372h7pca4sgxjv0pdx96xkgsfi180h3mb0vq8"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-cookie" ,ghc-cookie)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-network" ,ghc-network)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)
+ ("ghc-stringsearch" ,ghc-stringsearch)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-fast-logger" ,ghc-fast-logger)
+ ("ghc-wai-logger" ,ghc-wai-logger)
+ ("ghc-zlib" ,ghc-zlib)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-iproute" ,ghc-iproute)
+ ("ghc-void" ,ghc-void)))
+ (inputs
+ `(("ghc-wai" ,ghc-wai)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-text" ,ghc-text)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-vault" ,ghc-vault)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://github.com/yesodweb/wai")
+ (synopsis "Some basic WAI handlers and middleware")
+ (description "This library provides basic WAI handlers and middleware
+functionality.")
+ (license expat)))
+
;;; haskell.scm ends here