summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:27:35 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit7b72df8b7adb131321153d7d5e0d33cd5e6c3404 (patch)
tree01da446eff7de6f0f94386ab202d638fde86c1e2
parent39505126b17dd3a19c215d95f828d81ee45ec454 (diff)
gnu: Add ghc-css-text.
* gnu/packages/haskell.scm (ghc-css-text): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33a603ccb1..fe463010c7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1162,6 +1162,32 @@ aimed particularly at dealing efficiently with network protocols and
complicated text/binary file formats.")
(license bsd-3)))
+(define-public ghc-css-text
+ (package
+ (name "ghc-css-text")
+ (version "0.1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/css-text/css-text-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1xi1n2f0g8y43p95lynhcg50wxbq7hqfzbfzm7fy8mn7gvd920nw"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://www.yesodweb.com/")
+ (synopsis "CSS parser and renderer")
+ (description "This package provides a CSS parser and renderer for
+Haskell.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")