summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 13:14:55 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit81da1a45e80d9a71fb69d2e61ba5aab7dee4149d (patch)
treec5cf0dcab218f948e0d8266c87ff4cdedd1001c4
parent0ba563643ebcae725a73ee1986e3c3002a389755 (diff)
gnu: Add ghc-happy.
* gnu/packages/haskell.scm (ghc-happy): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 300469f93b..930df4a785 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -435,6 +435,32 @@ them.")
"This library provides an easy way to define command line parsers.")
(license bsd-3)))
+(define-public ghc-happy
+ (package
+ (name "ghc-happy")
+ (version "1.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/happy/happy-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1nj353q4z1g186fpjzf0dnsg71qhxqpamx8jy89rjjvv3p0kmw32"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ;; cannot satisfy -package mtl. Possible Cabal
+ ;; issue.
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)))
+ (home-page "https://hackage.haskell.org/package/happy")
+ (synopsis "Parser generator for Haskell")
+ (description "Happy is a parser generator for Haskell. Given a grammar
+specification in BNF, Happy generates Haskell code to parse the grammar.
+Happy works in a similar way to the yacc tool for C.")
+ (license bsd-3)))
+
(define-public cpphs
(package
(name "cpphs")